WordPress 后台升级时提示输入 FTP 信息

WordPress 的在线安装和升级实在方便,不过这功能有时候也不那么好用,在不同的服务器主机环境下就可能会有不同的效果。今天就在VPS下关于这个功能遇到点麻烦,当添加、删除、升级 WordPress 插件主题或者直接升级 WordPress 的时候,提示需要输入FTP账户信息,而且输入了FTP账户信息也不管用(无法连接服务器,不知道我哪里设施的不对)。

寻寻觅觅,找到三个方法,没错,是三个方法。

一、在 wp-config.php 里加入下面代码

define(“FS_METHOD”, “direct”);
define(“FS_CHMOD_DIR”, 0777);
define(“FS_CHMOD_FILE”, 0777);

我就是用这个方法解决了问题。

二、在 wp-config.php 里加入下面代码

define(‘FTP_HOST’, ‘ftp.yoursite.com’);
define(‘FTP_USER’, ‘Your_FTP_Username’);
define(‘FTP_PASS’, ‘Your_FTP_password’);
//如果你的 FTP 可以使用 SSL 连接,把下面设置为 True
define(‘FTP_SSL’, true);

省去重复登陆的麻烦

三、修改 WordPress 文件用户组,在ssh中执行类似以下的代码

chown -R apache /home/wwwroot/wordpress

不建议在 apache 中用这个方法,如果把文件所有权更改成其他的,可能会你设置的ftp账号没法修改文件了,fast-cgi倒是可以用这个方法。

PS:今天发现输入FTP密码其实也挺方便的,哈哈! —— 2012年7月16日



  1. 我一直在用第二个方法,不知道怎么了我的vps不管怎么设定都需要ftp密码,所以只能使用第二个方法了

  2. 作者你好,我昨天4.5.1也出现这种 情况 .。 但我升级到4.6后已经解决,但也谢谢你的文章吧