WD My Cloud Gen1 安装 Entware-ng

本文仅针对 WD My Cloud Gen1 3.0 固件。Gen1 3.0 固件基于老旧的 Debian 7,虽然可以 apt-get 安装软件,不过万一不小心更新了 libc,很可能会变砖,小心为妙。

Entware-ng 是为路由器、NAS 等设备打造的软件仓库,可以方便的安装上千款软件,如 aria2, dropbear, shadowsocks 等。

安装 Entware-ng 到 WD My Cloud

#删除原来的opt目录,ln链接到共享目录,防止系统升级重置等丢失
rm /opt -rf
mkdir /shares/Public/opt -p
ln -s /shares/public/opt /opt
cd /opt
#一键安装 entware-ng
wget http://pkg.entware.net/binaries/armv7/installer/entware_install.sh -O -|sh

#追加变量环境
sed -i '/\/opt\/bin/d' ~/.bashrc;
echo "export PATH=/opt/bin:/opt/sbin:\$PATH" >> ~/.bashrc
source ~/.bashrc

#把开机脚本加入rc.local
echo "/opt/etc/init.d/rc.unslung start" >> /etc/rc.local
#也许要把rc.local加入系统启动项
update-rc.d rc.local defaults 99

Entware-ng 的使用

#更新源
opkg update
#升级软件
opkg upgrade
#查找软件
opkg find shadowsocks*
#安装aria2
opkg install aria2
#删除 aria2
opkg remove aria2

WDMyCloud:~# opkg find shadowsocks*
shadowsocks-libev-config – 3.0.8-15 – shadowsocks-libev config scripts
shadowsocks-libev-ss-local – 3.0.8-15 – shadowsocks-libev ss-local
shadowsocks-libev-ss-redir – 3.0.8-15 – shadowsocks-libev ss-redir
shadowsocks-libev-ss-rules – 3.0.8-15 – shadowsocks-libev ss-rules
shadowsocks-libev-ss-server – 3.0.8-15 – shadowsocks-libev ss-server
shadowsocks-libev-ss-tunnel – 3.0.8-15 – shadowsocks-libev ss-tunnel
shadowsocksr-libev – 2.5.6-20170803-1 – libev port of ShadowsocksR.

关于 aria2 再啰嗦几句

aria2 安装后,根据需要修改配置文件 /opt/etc/aria.conf 。

如果下载不了 https 的链接,需要安装 ca-certificates, opkg install ca-certificates

 

相关链接:http://entware.net/

发表评论

电子邮件地址不会被公开。 必填项已用*标注